Author Topic: 1. CAT 9 engine battery not charging, 2. Onan Quiet Diesel 8000 Generator  (Read 2358 times)

0 Members and 1 Guest are viewing this topic.

Offline Joe Torreblanca

  • Newbie
  • *
  • Posts: 2
Hello Club Members,

Coach: 2006 Country Coach, 36' Inspire, with 8K Onan Quiet Diesel Generator

My wife and I drove our coach about 4K miles last year around the N/W area and had maintenance service done in Junction City, OR, including 4 new house batteries....did not program Zantrex.  We returned home and stored the coach.  The engine fired up in storage in Nov and Dec.  Upon getting the coach out of storage on Jan 15, 2013 for a trip to Quartzsite, AZ, the engine battery was dead and very little power in the house batteries.   I used a "hot box" to power the house batteries to power the generator to power the engine battery.  Got the engine started and took it home to prepare for the trip. 

Drove to Quartzsite with 2 other coaches (Monacos) and no problems.  We prepared to dry camp, but the Onan Generator would not stayed "o".  The Gen started Ok, long enough to deliver AC power in the coach, but would shut down on its own. Many tries, similar results.  I noted the Gen's coolant reservoir low, filled it with distilled water, to proper level...same results.  Noted a crack in the plastic case, need to replace that item, but the Gen did not stay on.  Survived with power from friend's 10K Generator. 

My other problem is that I had to jump start the engine battery with my tow vehicle.  Drove 4 hrs., engine volt meter reading 14 volts, stopped engine for lunch, started good to resume trip home, drove 2 hrs, volt meter still at 14 volts, arrived home, parked.  Next day engine battery could not start engine.

Called Onan HQ....advised tech of the cracked coolant reservoir tank, replied, "Oh, your replacement will be thicker plastic case ....like he knew of similar ongoing complaints.  Does anybody know of Onan Recalls for this problem?

Do I need to re-program the Zantrex system for the house batteries to charge my engine battery??  AAA examined engine battery, very good condition, why is it not charging, while my alternator delivers 14 volts, while on the road.  61/2 hrs on the road at 15.5 rpm should have been enough to fully charge the engine battery.  Thank you all for you time, for any response.   


 

Made appointment with local RV repair shop......but the problems are bugging me     

Offline kenbuck2

  • Newbie
  • *
  • Posts: 49
The repair shop is going to test the battery, check that the battery is getting the charging voltage, both of which it sounds like you've already done, then they're going to check for a draw on the battery. Is something left on and draining the battery? This assumes all the other visual check items are ok, like cables are clean and not shorted etc.

Has the rig been plugged in when stored? Has the onboard charger been charging the engine batteries previously? Have the batteries been maintained properly? Did the replacement batteries get all the wires put back on properly? There are a lot of possibilites and just one little problem can cause what you are experiencing.

Ken
Ken Buck
2007 Beaver, C-9 Cat, Allison 3000MH

Offline Joe Torreblanca

  • Newbie
  • *
  • Posts: 2
Ken,

Thank you for interest and time.

J.T.