Author Topic: Allison Transmission Error code  (Read 284 times)

0 Members and 1 Guest are viewing this topic.

Offline Clarice2015

  • Newbie
  • *
  • Posts: 5
Allison Transmission Error code
« on: September 23, 2019, 10:00:12 AM »
I'm at my wits end.  Have a 2015 Fleetwood with a Cummins ISL9 backed up by Allison 3000MH trans.  Bought used and owned about 1 year.  A few months after we bought it I started getting an error code on the dash LCD screen that says "Trans Oil Filter".  It comes on as soon as you turn ignition to warm up the glow plugs.  The trans fluid and filters had been replaced less than 3k miles prior to this by the previous owner and I have receipts from a Freightliner service center to prove it.  No change in shifting, etc... that I can tell.  I took it to my local Freightliner Oasis service center and they said they reset the computer code to clear it out.  It stayed cleared for about 250 miles and then popped back up.  I drove that way for about 1500 miles as I was in the middle of a trip.  I again took it back as I had a leaky radiator that ended up being replaced and they said they could not replicate the trans problem even though the error always comes up when I turn on the ignition.  When I picked it up, it was cleared off the LCD screen.  About 250 miles later it came back on again.
I'm guessing this is an error from differential pressure sensors across the filters to indicate the filters should be replaced.  I just can't imagine that needed to be done so soon after a fluid and filter replacement.  Nor can I understand why the code clears and then comes back on unless there is an actual problem or maybe a sensor is faulty.

Thoughts or suggestions, troubleshooting?

Offline Brett Wolfe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2524
Re: Allison Transmission Error code
« Reply #1 on: September 23, 2019, 10:03:38 AM »
Clarice,

Welcome to the Diesel RV Club.

Are there any stored diagnostic codes in the Allison (use shift pad to access).

Offline Clarice2015

  • Newbie
  • *
  • Posts: 5
Re: Allison Transmission Error code
« Reply #2 on: September 23, 2019, 12:52:35 PM »
I'll have to check. My MH is stored remotely so I won't be able to get to it until the weekend.
Thanks for the response.

Offline Clarice2015

  • Newbie
  • *
  • Posts: 5
Re: Allison Transmission Error code
« Reply #3 on: September 28, 2019, 04:26:00 PM »
Ok. Only one code shown
P088A
Can’t find that one in any of the literature.
I attached pics of the shift selector and LCD on dash
Mileage is 42,500 if that is of interest.
Thoughts?

I have been intermittently getting a low battery warning at startup.
The other codes similar to this one seem to be around power or ground issues with the TCM
Thanks

Offline Clarice2015

  • Newbie
  • *
  • Posts: 5
Re: Allison Transmission Error code
« Reply #4 on: September 28, 2019, 06:59:25 PM »
From manuals, the code I get it looks like the codes from a 4th Generation Allison and not the WTEC III. 
Any other ideas?

« Last Edit: October 01, 2019, 10:11:20 AM by Brett Wolfe »

Offline Clarice2015

  • Newbie
  • *
  • Posts: 5
Re: Allison Transmission Error code
« Reply #5 on: October 01, 2019, 09:40:06 AM »
Wondering if it could be a bad pressure switch on the filter life valve?
Guess I’ll get under there and trace the wiring some to see if there is damage.
Any other suggestions would be greatly appreciated.

Offline Brett Wolfe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2524
Re: Allison Transmission Error code
« Reply #6 on: October 01, 2019, 10:12:42 AM »
Give Allison a call: 800 252 5283