Author Topic: C7 power loss  (Read 1386 times)

0 Members and 1 Guest are viewing this topic.

Offline Rick

  • Newbie
  • *
  • Posts: 5
C7 power loss
« on: November 15, 2019, 10:44:04 AM »
I have a 2007 KW with a C7 cat engine.  I also have a pro-link diagnostic tool with the cat software.  The truck has been running great but over the past few years it will lose almost all power. When this happens the truck will start and run but will not move and sometimes will die when put in gear.  (it has an Allison Transmission) To get the truck to run I have used a couple of cans of Sea-foam in the diesel fuel tank and let it run for 15 or 20 minutes. This makes it run better but to get it to run with full power again I have to turn the truck off and restart it, then the truck will preform with more power.  Sometimes I have to turn off and restart multiple times to get it running correctly.  I was told that the fuel pressure regulator was the most likely culprit to this problem so when I lost power again which was a couple weeks ago I replaced that regulator.  It now starts and runs with limited power.  I have done a cutout test on the injectors and I am not finding any conclusive power loss on any one cylinder.  The truck has a rough idle and is slow to accelerate. When going up hills I am in a lower gear than normal and its running about 20-30 mph less than normal.  I have looked up the atmospheric pressure on the pro-link and its reading 11 plus. I live in southwest Wyoming at over 6000 ft. elevation. I have one logged event in the pro-link scan of low boost pressure. I also have a couple of actuation pressure faults from a couple months ago. I have changed the fuel filters and no more actuation faults have been logged. I have ran the actuation test and the actual pressure is within about 75 psi of the target pressure plus or minus but mostly higher.  Any help you could provide would be greatly appreciated.  If there are any tested I need to preform please let me know.

Thanks
Rick
Rick

Offline ziggyh

  • Full Member
  • ***
  • Posts: 245
Re: C7 power loss
« Reply #1 on: November 15, 2019, 07:46:59 PM »
Have you checked fuel pressure and quality.
When doing a cylinder cutout test I start.the actuation pressure test first and then run the cutout test at different pressures to isolate weak injectors and have found some will show up this way.
ZiggyH

2007 Revolution LE
C9

Offline Rick

  • Newbie
  • *
  • Posts: 5
Re: C7 power loss
« Reply #2 on: November 16, 2019, 05:01:04 PM »
Thanks Ziggyh for you reply.  I have not checked the fuel pressure.  Fuel quality is good and fresh. I will check fuel pressure and also run the cutout test with the actuation pressure at different settings.  Thanks again for you help.  I will post back my results.
Rick
Rick

Offline David.e.atherton

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 313
Re: C7 power loss
« Reply #3 on: November 17, 2019, 05:39:46 PM »
Rick, I would suggest install a test pressure gauge in the IAP Sensor port and cranking
engine note the pressure build of test gauge. Note it takes 870 psi to start engine but
checking cranking pressure many times you will see a fall off of lower pressure that is
below startup pressure. If there is any different in actual cranking pressure and the recommended startup pressure than remove valve cover and observation at the injector
base seat in the head for air oil bubbles coming around an injector. This is very possible
where your problem is located. The repair is o-rings on injector leaking with new o-rings
( 2 ) and backup retainer for o-ring. This is a area that is over looked and will cause your
low power. Ask Dave, Dave Atherton Retired Cat Mechanic

Offline Rick

  • Newbie
  • *
  • Posts: 5
Re: C7 power loss
« Reply #4 on: November 19, 2019, 08:18:23 AM »
Dave,
Thank for the reply and information. I will preform those tests today and I will report back my findings.
Thanks again,
Rick
Rick

Offline Rick

  • Newbie
  • *
  • Posts: 5
Re: C7 power loss
« Reply #5 on: January 06, 2020, 10:38:24 AM »
I have been working on a Cat C7 with a power loss.  I have changed the injector seals and had some improvement in power but it
still runs poorly. It will start fine but runs a little rough.  Taking off is the most noticeable power loss.  Also when it gets to 4th or 5th gear its
very rough and shakes quite a bit.  I have changes both fuel filters and checked the fuel quality.  Everything checks out good.  The Fuel pressure
tested at the secondary filter port shows a climb in pressure from 0 to about 70-80 and the it goes real erratic.  Jumping from about 15 psi to just over 80psi.  I have watched the test gauge and done a cylinder cut out test and it continues to be erratic all the time.
My Question is would a pressure regulator cause this problem or will it be the diesel fuel transfer pump that is on the back of the HEUI pump, or maybe something else?
Any info would be greatly appreciated.
Also thanks to Ziggyh and Dave for their input to get me this far. 
Rick
Rick

Offline David.e.atherton

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 313
Re: C7 power loss
« Reply #6 on: January 07, 2020, 05:28:22 AM »
Rick, there are two possible areas where your problem is located. First recheck your fuel
Supply on the suction side of fuel transfer pump for at higher rpm where skate occurs
and hold engine rpm at that point and looking for air in the clear line at suction line and
Clear line on the return fuel pressure regulator. There cannot be any air present at both points.
Second area that can produce the shaking Boost Pressure Sensor can cause this also.
Ask Dave, Dave Atherton Retired Cat Mechanic

Offline Rick

  • Newbie
  • *
  • Posts: 5
Re: C7 power loss
« Reply #7 on: January 08, 2020, 01:48:24 PM »
Thanks for The Information Dave.
I will check the fuel system on the vacuum side.
Thanks again,
Rick
Rick